Problems installing Dradis on Mac

I followed Dradis Framework GuidesDradis Framework Guides: Installing Dradis on MacOS

but I encounter the following problems after installing XCode

  1. When I run ‘rvm install 1.9.3’ I get this warning:

WARNING: Please be aware that you just installed a ruby that is no longer maintained (2016-02-24), for a list of maintained rubies visit:

http : //

Please consider upgrading to ruby-2.4.0 which will have all of the latest security patches.

  1. The tutorial says that something is supposed to happen when I ‘cd’ into the server directory, but on my mac, nothing happens.

Whent I examine the file it tells me:

This is not the Repo you are looking for!

New development is taking place in dradis/dradis-ce.

This repo contains 2007->2015 code, from Dradis v1 to v3.0.

This repo lives here for archeological purposes.

  1. Running I get recommended to ‘gem install bundler’, which I did. After that, running again I get told to ‘gem install sqlite3’, which I also did.


Congratulations. You seem to be ready to run the Dradis Framework.

Remember that you still need to go to the server/ folder and run:
-e bundle install

bundle install says

Could not locate Gemfile

I then turned to google after which I tried running, but I get instructions in the terminal that urge me to run ‘bundle install’.

  1. I then run bundle install in the server/ subdir (also found online), but this yields another error:

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

An error occurred while installing nokogiri (1.6.5), and Bundler cannot continue.
Make sure that gem install nokogiri -v '1.6.5' succeeds before bundling.

In Gemfile:
ruby-nmap was resolved to 0.7.0, which depends on

I tried to install nokogiri with “gem install nokogiri -v ‘1.6.5’”, which also fails.

Google tells me to add parameters to make this work on MacOSX Sierra:

gem install nokogiri – --with-xml2-include=/Applications/ --use-system-libraries

But that tells me that I need a higher version of ruby:

Fetching: mini_portile2-2.2.0.gem (100%)
Successfully installed mini_portile2-2.2.0
Fetching: nokogiri-1.8.0.gem (100%)
ERROR: Error installing nokogiri:
nokogiri requires Ruby version >= 2.1.0.

I’m at a loss here and am very open to any suggestions.

Best regards,

P.S.: I tried to install Dradis on my Debian8 laptop just to get different errors. Still fails.

Is it me, or is Dradis a very challenging program to get running?

The Mac guide you’re referring to is quite out of date, if you go to the website’s download page, choose: “Download for macOS Sierra” you’ll get a single .tar.gz file with Ruby, all dependencies and the app.

That should be the easiest way to get up and running.

Alternatively if you want to post the error messages on Debian 8 we can look into helping you with that too.

Thanks etd! Worked like a charm :slight_smile:

Is it maybe an idea that the old description on Dradis Framework GuidesDradis Framework Guides: Installing Dradis on MacOS is clearly marked as “legacy” or removed?

I might need additional help getting it running on Linux, but I’m just going to use the working version on my MacBook, now that I have it. Since it’s a web interface, I can access the Dradis instance on my MacBook over my LAN anyway.

Thanks again and with best regards,

1 Like

Rachael with the support team here. Thanks, @MeetInTheMiddle, we’ll look into updating the old legacy guide to prevent other confusion in the future!

Re: Linux, when you get to that point, our Kali Linux guide is here: Installing Dradis on Kali Linux | Dradis Framework. Keep us posted with any questions!