Issue installing dependencies using

I am new to dradis and am trying to get started, however cannot due to some install issues. I followed the instructions here Dradis Framework GuidesDradis Framework Guides: Installing Dradis on Ubuntu. However, whenever I run sudo ./ from the dradis dir I get “An error occuerd while installing nokogiri(1.5.0), and bulder cannot continue. Make sure that gem install nokogiri -v ‘1.5.0’ succeeds before bundling”. I tried “sudo gem install nokogiri – --use-system-libraries” and it installs version 1.6.X but when running I get the same error. I also already tried apt-get update && apt-get upgrade. I am running Ubuntu 14.04.
I have never used Ruby/On Rails before so any help at all with this topic would be much appreciated.

Try to install the exact version of nokogiri:

sudo gem install nokogiri -v '1.5.0'  --use-system-libraries

Then check the error messages from that.

So assuming you’re directly following the instructions in that guide there’s a couple of places I can see where you might be getting tripped up.

  1. The guide focuses on using rvm for ruby instead of using system ruby. when you’re installing gems with rvm (unless you’re installing rvm system-wide which isn’t the default) you shouldn’t use sudo as this will try to install at a system level rather than a user level. (Cannot use RVM-installed Ruby with sudo - Stack Overflow) Also when you’re doing ./ you shouldn’t need sudo there either (assuming you’re just installing in your home directory)

  2. pre-requisites for nokogiri. There’s a couple of libraries which aren’t installed in Ubuntu by default which are needed for nokogiri. If you do

    sudo apt-get install libxslt-dev libxml2-dev

that should install the required libraries (more info Installing Nokogiri - Nokogiri)

Using the ./ script should pick up some of this problems. For instance the nokogiri dependencies are caught by:

Oh man, I didn’t get any notifications about responses to my topic…I’ll have to look into that.
Let me start off by saying thank you for the prompt replies and sorry I was unable to get back to you guys sooner. Though it seems my issue was related to what raesene said. I tried installing dradis from instruction not from the official site so I used ‘sudo’ in a number of places and wasn’t consistent. So I did a fresh install of Ubunto on my VM and followed the official dradis site instructions and everything seems to be working now.

Thanks!! :smile: