Help with installation


I Use System kali linux … When I installation dradis

This problem appeared :
An error occurred while installing nokogiri (1.5.0), and Bundler cannot
Make sure that gem install nokogiri -v '1.5.0' succeeds before bundling.

I have nokogiri

help plzz

Hi stroker,

Kali already ships with Dradis, can you use that version?

We will also get v3.0 in Kali as soon as possible.

And we’re preparing self-contained 3.0 packages that should be ready by the end of the week…

Would any of the above work for you?


How do I turn it on !

/usr/lib/ruby/vendor_ruby/bundler/rubygems_integration.rb:187:in stub_source_index170': uninitialized constant Gem::SourceIndex (NameError) from /usr/lib/ruby/vendor_ruby/bundler/rubygems_integration.rb:353:in stub_rubygems’
from /usr/lib/ruby/vendor_ruby/bundler/rubygems_integration.rb:250:in replace_entrypoints' from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:14:in setup’
from /usr/lib/ruby/vendor_ruby/bundler.rb:107:in setup' from /usr/lib/ruby/vendor_ruby/bundler/setup.rb:17:in <top (required)>’
from /usr/local/lib/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:54:in require' from /usr/local/lib/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:54:in require’

Hey Daniel,
Thanks for all the amazing you and your team are doing :slight_smile: Are self contained 3.0 packages ready? Would these install issues with Kali 2.0?


Kali 2 has Dradis 3.0 already, and they have Dradis 3.0 packages on the main site. However, this is the RC3 release in which you can’t export anything or you get errors.

They’ve been recommending doing an install from git since October 2015, which is apparently a “fixed” version, but for me it actually caused more problems with all of the ruby dependencies required and I gave up. I keep checking back to see if there’s an RC4 or a 3.0 final package.

Seems like 100% of effort is going into Dradis Pro since they make money off of it. However, I can’t use Pro where I work because the systems I wanted to use Dradis on are airgapped from the internet, and from what I gathered, Pro is a cloud-based subscription model. It’s unfortunate, really - I can’t find anything else quite like it, and I just can’t get it to work.

Note: If a dev reads this, a “trash bin” for deleted items would be awesome. A guy accidentally clicked delete on something he put a bunch of info into and it was gone forever :frowning:

You may be able to export PDF reports by commenting line 51 of
[dradis directory]/lib/vendor/ruby/2.1.0/bundler/gems/dradis-pdf_export-5xxxx/lib/dradis/plugins/pdf_export/exporter.rb

However, I’m still not able to get HTML and CSV export working. If I use github version, I run into theme errors for which I’ve posted a question at SnowCrash theme FATAL error

That sounds like the same error I got with the github version.

And thanks for the info. Does it do anything to fix uploads? That was another issue I had with the RC3 and Kali packages.

Do you mean namp import? That can be resolved by commenting out ine 35-37 and 47 - 55 of
[dradis directory]/lib/vendor/ruby/2.1.0/bundler/gems/dradis-nmap-b63ed263a379/lib/dradis/plugins/nmap/importer.rb

No, I mean I couldn’t get anything to upload. Like images to attach to the notes.

yeah, I’m still having issue with attachments. It does not do anything at all. It’s like “start” button has no method associated with it.

@sininspira @qasimchadhar please give a try to the latest v3.1rc1, it should address the upload issues.

More info:

Works like a charm:) Thanks