A few issues on Kali 2.0 Dradis 3.0.0


I just recently decided to give Dradis a shot, however, I’ve run into a few issues… Most of the issues seemed to have been fixed, but I can’t seem to update the installation on Kali to get Dradis up-to-date. I’ve tried to git pull from the repo from within the /usr/lib/dradis/ directory, but it gives me the error: fatal: Not a git repository (or any of the parent directories): .git

I’ve updated Kali itself, but it doesn’t seem to grab anything for Dradis. Some of the issues I’m having are clicking the ‘upload’ button for an attachment doesn’t do anything, the configuration page doesn’t seem to exist, and I can’t seem to export. Again, I’m pretty sure most, if not all, of these issues have been addressed, however, I can’t seem to get the installation on Kali to update.

Any help is much appreciated!

Hi @0xroguepacket,

what is the issue you are looking to fix by updating Dradis?

I suspect this is caused by the Kali version of Dradis being packaged as a .deb file and not directly pulling from the repo.

If you let me know the bug / problem. I can maybe either point you to a workaround or work with the Kali team to get their .deb file updated.


I also have issues on running the download on the terminal
pls help

Hi @anonymou_s, have you checked out our updated guide to installing Dradis on Kali here?

We recommend using the instructions in this guide so that you can use the latest version of Dradis from Git.

I’ve done that and I’m still having issues. My post about it is apparently stuck in the moderations queue…

Thanks for bumping this thread! I just rescued your post from the moderation queue and responded to it here: Install problem on kali rolling

Hi @rachkor I have checked your updated guide but seems it still not working.
i m using kali in vmware workstation.

Hi @akku065 are you running into the same error message (fatal: Not a git repository (or any of the parent directories): .git) or another error? If you’re running into a different error, could you open a new topic and let us know more there? Any details (error messages, screenshots, etc) you can provide would be appreciated!

No Error or nothing.just while running it in firefox page is not loading.
I am just a beginner not able to resolve this

Hi @akku065 we can help with this! I just need more information from you. Could you post a screenshot or two showing the command line and the browser when you’re launching Dradis? That should help us start to understand what’s going on so that we can get this sorted out for you.

Hi @rachkor I have attached a video with my previous reply.
Sharing again.

@akku065 Apologies, I’m not seeing any videos. Could you link me directly?


@akku065 thanks for this! It looks like you haven’t walked through steps in the installation guide here:

Can you start with the dependencies in that guide and then move on to the Installing Dradis from Git guide? That will ensure that you’re running the latest version of Dradis. Sidenote, you’ll eventually be launching Dradis with $ bundle exec rails server instead of $ service dradis start.

Hi @rachkor
It Showing ERROR
Could not locate Gemfile or .bundle/ directory

AND Could not connect to Redis at Connection refused


When are you seeing this error? Could you post the full output in your command line or a screenshot showing more details?

I assume you’re getting this error when you run $ bundle exec rake resque:work - is that correct? It looks like the Redis server isn’t up and running on your local system. Can you check out the troubleshooting steps here? Installing Dradis on Kali Linux | Dradis Framework

Hi @rackhor
After checking the trouble shoot and running redis-cli ping
it showing error Could not connect to Redis at Connection

But as i run redis-server it showing this

Not Understanding what to do Next


Were you able to resolve the first error? (Could not locate Gemfile or .bundle/ directory)

We need to have the Redis server running in the background before running the rake task. Was the Redis server running when you got the Connection refused error? If not, I think that will resolve the error. Keep this tab/window open in your terminal (don’t shut down the Redis server), then run the $ bundle exec rake resque:work command again in a new terminal tab/window. Are you able to successfully run it then?