Struggling to get Dradis working on OS X {UPDATED! PLEASE RESPOND! 16th FEB

Hi guys,

First post here and I need help.

I’ve followed this guide to set up Dradis on my Macbook pro:

I’ve followed the steps carefully but when I got to the end of step two and changed directory to the server directory the guide says I should be prompted with the following message

Do you wish to trust this .rvmrc file? (/home/etd/dradis-git/server/.rvmrc)y[es], n[o], v[iew], c[ancel]> yUsing /Users/etd/.rvm/gems/ruby-1.9.3-p125 with gemset dradis

But I wasn’t prompted with this so I moved on through the rest of the installation, no errors.

After I run I get the following message:
=> Notice: server is listening on all interfaces ( Consider using (–binding option)

If I run ./ -b -p 3004 it seems to start fine but then when I go to the web page I get
Internal Server Error Missing secret_token and secret_key_base for ‘production’ environment, set these values in config/secrets.yml

I tried creating a brand new directory and running through all the instructions again but get the same issue.

I’m on OS X 10.10.2 (Newest version)

Any help would be massively appreciated. I’m guessing this is a dependancy/gemfile issue but I can’t figure it out.


It looks as if you are mixing the install instructions for Dradis 2.9 (in that link) with the code for Dradis 3.0. Could that be the case? You can check if there is an ./engines folder in the directory. If there is, then your code is 3.x.

If you want to go ahead with 3.x see this thread:

If you want to use 2.9, then you’ll have to checkout the legacy-2.x branch from the repo and follow the original instructions.

I recommend you stick to the 3.x, although it is still a bit rough around the edges.

Let us know how it goes.


Thanks for the response mate, that’s not working either unfortunatly, when I run ruby bin/setup I get the following:

Bradleys-MacBook-Pro:~ bradleyflay$ mkdir dradiswillwork
Bradleys-MacBook-Pro:~ bradleyflay$ cd dradiswillwork
Bradleys-MacBook-Pro:dradiswillwork bradleyflay$ git clone GitHub - dradis/dradis-legacy: This is a LEGACY repo head to
Cloning into ‘dradisframework’…
remote: Counting objects: 18234, done.
remote: Compressing objects: 100% (74/74), done.
remote: Total 18234 (delta 15), reused 1 (delta 0)
Receiving objects: 100% (18234/18234), 102.50 MiB | 5.20 MiB/s, done.
Resolving deltas: 100% (9174/9174), done.
Checking connectivity… done.
Bradleys-MacBook-Pro:dradiswillwork bradleyflay$ cd dradisframework
Bradleys-MacBook-Pro:dradisframework bradleyflay$ ruby bin/setup
== Installing dependencies ==
Resolving dependencies…
The Gemfile’s dependencies are satisfied

== Copying sample files ==

== Preparing database ==
The path /Users/bradleyflay/dradiswillwork/dradis-html_export does not exist.

== Removing old logs and tempfiles ==

== Restarting application server ==

Somebody is looking at this.

Whist the original issue was easy to pinpoint (a dependency issue in html_export) solving it identified a number of other problems derived from recent changes in Rails, which in turn cascaded into a series of minor fixes.

Rest assured that we will get back to when the issues are solved.

In the mean time, feel free to help debugging and submit a pull request if you spot any problems.


All issues should be solved by now.
Can you please repeat the installation process and tell us how it goes?
Thanks a lot.

Thanks guys. It seems to install now but I’m still having issues. When I start the server and go to the address in any browser I get this:

Oops, your Dradis server isn’t quite ready to go.
You need to configure your Dradis server before it is ready to use.

Grab a system console and:

cd /Users/bradleyflay/dradiss/dradisframework
RAILS_ENV=production bundle exec thor dradis:reset
If you’ve already configured your Dradis, you need to reset the password:

cd /Users/bradleyflay/dradiss/dradisframework
RAILS_ENV=production bundle exec thor dradis:reset:password

I’ve ran both sets of commands and get the same issue, I’ve set a password when I run the second set of commands.

Any help is appreciated.


Anyone got any ideas?

Forever Alone

20 characters

I have followed the Dradis 3 instructions but when I run bundle exec rails server I receive

The git source git:// is not yet checked out . even if I run bundle install again

Hi @davbrew2005,

It looks like this is likely an environment-specific error. Have you tried troubleshooting that error message? I found this StackOverflow thread that might be a good starting place: ruby on rails - is not checked out... bundle install does NOT fix help! - Stack Overflow (Note: dradis-ce is automatically running in development mode)
If the thread above doesn’t do it, what about the troubleshooting steps here?

If you can’t get around the error, would installing Dradis on Cloud9 work for you? Installing Dradis on Cloud9 | Dradis Framework

Keep us posted with any updates!