CSRF problems with Firefox

I have been trying to log in to Dradis in Kali, always getting the same error:

I then reinstalled Dradis but still got the same error.

After some googling, I tried modifying application_controller.rb as suggested in SO but the problem persisted. I then went to sign up for this forum and hit a similar problem when attempting to confirm my email: I was redirected to a page that simply said [“BAD CSRF”]

I then resorted to using chrome and was finally able to join the forum.

Does anyone know why Firefox does this? I can’t run chrome as root in my Kali VM so I still have not been able to log in. Any suggestions?


Managed to get chrome to run as root in Kali but still get the same error:

This error happens when you provide the wrong shared password in the login form. A couple of options:

  1. Reset the password so you can sign in with the right creds.
  2. Apply this patch: Warden - fix :failure_app config by etdsoft · Pull Request #432 · dradis/dradis-ce · GitHub