Dradis Ce - Sign in Problem


i am using Dradis Ce on Kali Linux Live usb, i am on my second day using the framework and i forgot my pass and had to changed it, i used:

bundle exec thor dradis:reset:password

without success though because i had to install the missing gems,

bundle install
i installed the missing gems and then i successfully changed my password.

unfortunately i cant login with the new password that i set,

this is the page i got redirect to,
ActionController::InvalidAuthenticityToken in SessionsController#create

Rails.configuration.middleware.use Warden::Manager do |manager|
manager.default_strategies :shared_password
manager.failure_app = ->(env) { SessionsController.action(:new).call(env) }

Can anyone help me on this?

i tried again to set a new password, without login success


Hi Alex,

Unfortunately, the dradis:reset:password command is not working right now. To reset your password run, these commands:

$ bin/rails console
> Configuration.find_by_name('admin:password').update_attribute(:value, ::BCrypt::Password.create(<password>))

Replace <password> with your new password. After running the commands, log in to the app again to see if it worked.

Keep us posted!

- Aaron