Problem Running Dradis with Redis on Ubuntu

Hello folks at Dradis!

I recently installed Ubuntu on my pc, and fell in love with Dradis while using Kali Linux so I thought I'd give it a shot to install it on Ubuntu. I followed the steps on the download page. I downloaded the tar.gz package and did what it said for "How do I run it". I installed the redis-server with sudo apt-get install redis-server then I tried running the scripts ./dradis-webapp && ./dradis-worker but it won't work. I keep getting this output in the terminal. Thanks!

johndoe@johndoe-FM8760:~/Desktop$ cd dradis/
johndoe@johndoe-FM8760:~/Desktop/dradis$ ./dradis-webapp && ./dradis-worker
/home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/execjs-2.6.0/lib/execjs/runtimes.rb:48:in autodetect': Could not find a JavaScript runtime. See for a list of available runtimes. (ExecJS::RuntimeUnavailable) from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/execjs-2.6.0/lib/execjs.rb:5:in module:ExecJS
from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/execjs-2.6.0/lib/execjs.rb:4:in <top (required)>' from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/uglifier-2.7.2/lib/uglifier.rb:3:in require’
from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/uglifier-2.7.2/lib/uglifier.rb:3:in <top (required)>' from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler/runtime.rb:76:in require’
from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler/runtime.rb:76:in block (2 levels) in require' from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler/runtime.rb:72:in each’
from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler/runtime.rb:72:in block in require' from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler/runtime.rb:61:in each’
from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler/runtime.rb:61:in require' from /home/johndoe/Desktop/dradis/lib/ruby/lib/ruby/gems/2.2.0/gems/bundler-1.9.9/lib/bundler.rb:134:in require’
from /home/johndoe/Desktop/dradis/lib/app/config/application.rb:12:in <top (required)>' from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/railties- require’
from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/railties- block in server' from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/railties- tap’
from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/railties- server' from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/railties- run_command!’
from /home/johndoe/Desktop/dradis/lib/vendor/ruby/2.2.0/gems/railties- <top (required)>' from /home/johndoe/Desktop/dradis/lib/app/bin/rails:4:in require’
from /home/johndoe/Desktop/dradis/lib/app/bin/rails:4:in `’

Thanks for reaching out! Can you try installing the latest version of Dradis from git using this guide? Installing Dradis from Git | Dradis Framework
(we’re adding a Step #8 to that guide that is currently missing on the install guide, details here: Issues with uploads)

That should get you around the errors you’re running into now. Give it a try and keep us posted with any updates!

Alright so I got through the installing from git steps. I had to install A TON of gems and dependencies but I got through it. I’m held up at the part when starting Dradis in a browser. I ran the command “bundle exec rails server” the server is running, so I do the last step which is pointing my browser at http://localhost:3000 I did that and it would not come up. it just kept trying to connect, then it would say it took too long to connect. So I thought maybe I had to run the server as root. So I tried that and now it won’t work running as root or nonroot. I think I messed something up somewhere. I’m not very knowledgeable with web-servers or ruby on rails so I’m stuck. I keep getting this everytime I try going to http://localhost:3000 I think running it as root broke it.

Alright so I just noticed that it said on the screenshot, "To resolve this issue, run: bin/rake db:migrate RAILS_ENV=development

So I did just that, I ran it in the terminal, started up rails server again. It’s just not working, I went to http://localhost:3000 and it says it refused to connect. It shows the little dradis logo in the tab title so it is Dradis trying to run. Hahah ok so now I’m totally lost, I’m in a “No mans land”. Please help if you can, I tried getting as far as I could.

Terminal output:

=> Booting WEBrick
=> Rails 4.2.6 application starting in development on http://localhost:3000
=> Run rails server -h for more startup options
=> Ctrl-C to shutdown server
[2016-07-08 14:41:40] INFO WEBrick 1.3.1
[2016-07-08 14:41:40] INFO ruby 2.3.1 (2016-04-26) [x86_64-linux-gnu]
[2016-07-08 14:41:40] INFO WEBrick::HTTPServer#start: pid=19348 port=3000
^C[2016-07-08 14:41:43] INFO going to shutdown …
[2016-07-08 14:41:43] INFO WEBrick::HTTPServer#start done.


We’re so close!

Did you mean to shut down the server? In the terminal output you sent it shows:

^C[2016-07-08 14:41:43] INFO going to shutdown ...

The ^C looks like you might have inadvertently shut down the server by hitting CTRL + C right after it got up and running. Can you try the $ bundle exec rails server one more time and confirm it’s still up before heading over to http://localhost:3000?

Fingers crossed over here, keep us posted!

hahaha I got it to work. I just restarted rails server! After all this time I finally got it up and running so now my life’s easier! Thanks for all your help rachkor!

1 Like

Great news! High fives all around. :raised_hand:
Glad we got it sorted out. Enjoy playing around with Dradis and have a great weekend!