New install of Dradis on Kali not working


I’m fairly new to Kali and completely new to Dradis. I couldn’t find a solution by searching, so I thought I’d ask here. I’m trying to set Dradis up on a WLS instance of Kali.

I went through the install steps here and then here.

Everything seemed to go fine. But when I run the last command to set up the app: bundle exec rails server

I get this:

 => Booting Unicorn
 => Rails 5.1.6 application starting in development on http://localhost:3000
 => Run `rails server -h` for more startup options
 E, [2018-07-27T13:25:42.051664 #17203] ERROR -- : [::1]:3000 {:tcp_defer_accept=>1, :accept_filter=>"httpready", :backlog=>1024, :tcp_nopush=>nil, :tcp_nodelay=>true}: Protocol not available - setsockopt(2) (Errno::ENOPROTOOPT)

Followed by a number of socket commands, ending in this:

 I, [2018-07-27T13:25:42.054428 #17203]  INFO -- : listening on addr=[::1]:3000 fd=14
 I, [2018-07-27T13:25:42.055080 #17203]  INFO -- : worker=0 spawning...
 I, [2018-07-27T13:25:42.071841 #17203]  INFO -- : master process ready
 I, [2018-07-27T13:25:42.073974 #17215]  INFO -- : worker=0 spawned pid=17215
 I, [2018-07-27T13:25:42.074682 #17215]  INFO -- : worker=0 ready
 E, [2018-07-27T13:25:42.075288 #17215] ERROR -- : listen loop error: Invalid argument - accept (Errno::EINVAL)

It then displays an infinite loop of unicorn socket commands and that same “listen loop error”.

Any suggestions?

Hey @Philomorph, thanks for reaching out! I’m completely sure what’s happening just yet but we’ll get this sorted! First, could you try running Dradis on a different port?

$ bundle exec rails server -p 1234

If that doesn’t do the trick, can you give me more details on what version of Kali you’re running? I tested using the latest version of Dradis CE on Kali rolling but that may not be replicating your setup well. Keep me posted!

I get the same result :frowning:

I’m running the Windows Linux Subsystem (WLS) version of Kali, available from Offensive Security via the Windows Store.

lsb_release returns:

No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: kali-rolling
Codename: kali-rolling

Hi @Philomorph. Unfortunately, we can’t replicate this issue in Kali. I’m guessing there is something with the WLS version of Kali that’s not working with the app server here. Have you tried a different approach with virtualizing a Kali Linux instance, say using VirtualBox/VMWare with the latest Kali image?

Hey @Philomorph, sorry about the delay! I’m currently fighting with a Windows error (imagine that!) to try to get the OffSec Windows Store version downloaded and running on my local system. While I work on that, want to try a possible fix? Unable to execute `rails` in WSL(Windows Subsystem for Linux) · Issue #26054 · rails/rails · GitHub