On the Export Manager there are no report formats listed

I have searched and cannot find anything to point me in the right direction to resolve this issue. I have installed Dradis-CE and imported a BurpSuite report to load issues into the project. However, when I attempt to Export to a HTML report there are not format files listed in the selection box. I have verified that the basic and default report formats are in the /templates/reports/html_export folder. Thank you in advance for your help.

  1. Did you install from by cloning from GH?

  2. Did you run (./bin/setup) - Installing Dradis from Git | Dradis Framework

  3. What are the contents of your Gemfile.plugins file?

  1. Yes.
  2. Yes
# Select the Framework plugins you want to use. Uncomment to enable, comment to
# disable.
# After making changes run the following to update dependencies:
#   $ bundle

# ----------------------------------------------------------------- Calculators

# ---------------------------------------------------------------------- Export
# gem 'dradis-json', '~> 4.5.0'

# ---------------------------------------------------------------------- Import
# gem 'dradis-mediawiki', '~> 4.5.0'
# gem 'dradis-vulndb', '~> 4.5.0'

# ---------------------------------------------------------------------- Upload

Additional Info: I tried to add the gem export-html line to this file and the error message that came back said another instance was already defined in ./dradis-ce/Gemfile line 238. Everything else in the product seems to be working but there are no options in the Export Manager selection box. (Screenshot attached)

I see that the export integrations are all loaded (otherwise they wouldn’t show in the tab strip).

There’s been a recent change in Bootstrap versions and that seems to be the issue (the tabs don’t switch) /cc @MattBudz I can replicate by cloning a fresh CE repo.

Sorry for the hassle, and watch this space for an update!

Hi @timcbell It’s possible that your app and gems are on different versions. Can you pull the latest version of the dradis-ce repo? After pulling the latest version of the repo, your Dradis app and gems should now all be on v4.9.0. You can confirm this by checking these lines in your Gemfile. If you have a Gemfile.plugins file, ensure everything is also set to v4.9.0 in there as well.

Once you are on v4.9.0, the tabs should look like this:

Notice we now have tabs labeled as “HTML”, “CSV”, etc, rather than “Generate advanced HTML reports”. This will be an easy indicator that your plugins are set to the latest version.

Once you have the latest version, the tabs should switch for you just fine. I did notice another bug, where the HTML tab doesn’t load automatically on page load but once you click on any tabs, the tabs will work.

I’m working on fixing the HTML tab to show up automatically.

Let me know if this sorted things out for you.

Thank you. That did resolve the issue and I can now see the HTML templates. However, I am not able to generate a report as when I change an issue to Published hit the Export Published Records button I get an error (see attached screenshot). I am looking at the error now. Thanks again for your help on the original issue.

Hi @timcbell ! This seems to be caused by the templates not being updated as part of our recent Liquid implementation, apologies for that! I now have a working fix for this here: Fix basic template and include rails text helper by aapomm · Pull Request #68 · dradis/dradis-html_export · GitHub

To try it on your instance, update this line in your Gemfile

gem 'dradis-html_export', '~> 4.9.0'


gem 'dradis-html_export', github: 'dradis/dradis-html_export', branch: 'fix-default-templates'

Then run bundle install and restart your server. If you want to use the basic.html.erb template, you may have to regenerate it by first deleting the file dradis-ce/templates/reports/html_export/basic.html.erb then restarting your server.

Let me know if that worked for you!

Sorry for the delay in responding, I have not been able to get back to this project until now. This resolved my issue. Thank you very much for your help.