No import possible

Hello there!

My name is Jan and I am new to this forum.
I try to upload output from nmap or openvas to dradis ce but I get the same error messages:

[04:11:15] Small attachment detected. Processing in line.

[04:11:15] Parsing Nmap output from /usr/lib/dradis/attachments/3/nmap-zuhause.xml…

[04:11:15] Done.

[04:11:15] Validating Nmap output…

[04:11:15] Done.

[04:11:15] There was a fatal error processing your upload:

[04:11:15] undefined method `project_id’ for #<Node:0x00007f1ebc481070>

[04:11:16] /usr/lib/dradis/ruby/2.5.0/gems/activemodel-5.1.6/lib/active_model/attribute_methods.rb:432:in `method_missing’

[04:11:16] /usr/lib/dradis/ruby/2.5.0/bundler/gems/dradis-plugins-5ff9d71c05de/lib/dradis/plugins/content_service/nodes.rb:40:in `create_node’

[04:11:16] /usr/lib/dradis/ruby/2.5.0/bundler/gems/dradis-nmap-4dc26f25433a/lib/dradis/plugins/nmap/importer.rb:31:in `block in import’

[04:11:16] /usr/lib/dradis/ruby/2.5.0/gems/ruby-nmap-0.9.3/lib/nmap/xml.rb:293:in `block in each_host’

[04:11:17] /usr/lib/dradis/ruby/2.5.0/gems/nokogiri-1.8.3/lib/nokogiri/xml/node_set.rb:204:in `block in each’

[04:11:17] /usr/lib/dradis/ruby/2.5.0/gems/nokogiri-1.8.3/lib/nokogiri/xml/node_set.rb:203:in `upto’

[04:11:17] /usr/lib/dradis/ruby/2.5.0/gems/nokogiri-1.8.3/lib/nokogiri/xml/node_set.rb:203:in `each’

[04:11:18] /usr/lib/dradis/ruby/2.5.0/gems/ruby-nmap-0.9.3/lib/nmap/xml.rb:292:in `each_host’

[04:11:18] /usr/lib/dradis/ruby/2.5.0/bundler/gems/dradis-nmap-4dc26f25433a/lib/dradis/plugins/nmap/importer.rb:29:in `import’

[04:11:18] /usr/lib/dradis/app/controllers/upload_controller.rb:93:in `process_upload_inline’

[04:11:19] /usr/lib/dradis/app/controllers/upload_controller.rb:50:in `parse’

[04:11:19] Worker process completed.

The content itself uploads, but only as an attachment and does not create nodes.
Then I also tried uploading templates - without any issues!
Also a fresh install of dradis does not make any difference.

Do you have any advice on this? (Before I wrote this it took me 2 days on the internet but there wasn’t a suitable solution)

What version of Dradis / OS are you on?

Could it be related to:

Thanks for the reply!

I think it was my fault - I used the preinstalled version of dradis in kali.
Some hours later I made it work from the github version.
(My first tries with the github version didn’t work as well because I never used git before)

So this post can be closed, dradis runs fine now!!!

@jangilgan, no problem! Great to hear that things are working. I’ll close the thread and you keep us posted if any other questions come up.