Export - unused links

I have just installed the latest version of Dradis-ce from github on cloud9. I have noticed that there are two unclickable tabs on the Export Manager.
Please see attached image

Not sure if they’re supposed to be there or if its for the future


Hey @markajbell,

They’re supposed to be clickable, what OS and Browser (+version) are you using?


Win 10 and the latest version of chrome. The 1st two are clickable but the
other two are not.

Tried in Firefox. Sam thing. one other thing i noticed is that when you
click on the link below the Generate advanced HTML reports tab is not
accesible. You cannot click it either.

  • Export results in CSV format


Ready when you are!


GIAC Certified Penetration Tester (GPEN) - Credly]

I’m currently seeing the same thing – Firefox 49.0.2, Chrome Version 54.0.2840.71 (64-bit), and Safari Version 10.0 (11602. Similar to the above reporter, after clicking on “export results in CSV format” I can’t click back to “Generate Advanced HTML Reports”.

I also have issues elsewhere in the UI – for instance, on any given node, I can’t click the “+” next to “notes” or “evidence”, and can’t clock “recent activity”, or “edit” (next to properties). I can click “+ add subnode”, “delete”, “rename”, and “move”, but once I click, for example, “rename”, the dialog box becomes unresponsive. I initially see, for a brief second, a cursor in the “new name” field, but as soon as I try to interact with it, I lose all control. Can’t type the new name, or click “rename” or “close” or “x” (top right). Only way out is to click somewhere outside the dialog box and it goes away.

@markajbell @dbyler I think we’ve got a solution for you! Can you test out the fix in the comment below and let me know if it resolves the problems on the export page?

By default, the try-pro div wasn’t being hidden and was preventing the middle of the /export page from being clicked. See the screenshot below:


This error has been fixed and merged. To apply the fix:

  1. If Dradis is currently running, shut down the rails server with CTRL + c in the command line
  2. Navigate to the /dradis-ce folder on your local system
  3. Run the following in the command line
    $ git pull origin master
    $ bundle exec rails server


No this didn’t fix.

Please see attached png.

I have edited the _modals.html.rb but inspecting the updated export page still shows the old values.


@markajbell Can you check line #1 of dradis-ce/app/views/layouts/snowcrash/_modals.html.erb. It looks like you’re still missing the aria-hidden="true" part. If you’d rather apply the local patch (the end result will be the same as running the git pull), you just need to change both files here: Hide the try-pro div by default · dradis/dradis-ce@3ab66f5 · GitHub
Don’t forget to restart Dradis after saving the changes!

http://discuss.dradis.com/users/rachkor @rachkor.

I have edited the file under the filesystem on c9. Please see screenshot

I did a git pull request but git gave an error.

Also edited the app/assets/stylesheets/snowcrash/modules/modals.scss file and added the hidden bit, still no joy


@markajbell if you’ve edited both files (_modals.html.erb + modals.scss) you should be good to go. Do you have more than one terminal tab open in your c9 workspace? If so, make sure that you shut down Dradis in the other tab with a CTRL + c, then restart it with $ bundle exec rails server -p $PORT -b $IP

_Cloud9-specific commands from: http://dradisframework.org/documentation/install_cloud9.html_

The git error you sent over is a merge conflict. Basically, git doesn’t want to overwrite the local changes you made to the _modals.html.erb file unless you say it’s ok. If you’d rather go the git route, let me know! But since you’ve already made the local changes, I think we can solve this quicker with the restart above.

@Rachkor. Online on slack. Mark

Quick Update: @markajbell and I resolved this on Slack. If anyone is on Cloud9 and running into similar problems, make sure you are running the commands directly from ~/workspace and not the /dradis-ce folder. Mark, thank you for your help!