Dradis Pro - Redis not starting

Dradis Pro has been running without issues for months, but just recently I attempted to duplicate a project and since then it’s been ‘Creating a new project’, but clearly it’s hanging. Other projects when attempting to access them caused the redis error.

I’ve checked and Redis isn’t running, and even when I revert to a backup from the previous day, I still get the same issue. Any ideas?

I’ve tried to run redis but it doesn’t run.

Weird! What’s the error you get when running redis? As dradispro:

$ sudo /etc/init.d/redis-server status

and also

$ sudo /etc/init.d/redis-server restart

Hi etd, unfortunately, nothing is in the Redis logs, and neither is there any output for journalctl apart from the service timing out. I’ve extended the timeout to 5 minutes, which didn’t work, and now testing with 20 minutes. Although, considering it’s redis, it should run in a matter of seconds…

@LiterallyBlah Rachael with the Dradis support team here.

You mentioned:

I’ve tried to run redis but it doesn’t run.

What have you tried and what is the output?

Hi Rachkor, there is no output nor is there anything in the logs from the same day as attempting to run redis.