Current install guide?

Hey folks,

I am having some trouble installing the Dradis Community Edition. I’ve tried a few times on a few machines running Ubuntu.

Could someone give an install guide for the latest Dradis on a stock Ubuntu box, where all the plugins for importing will work, as well as exporting?

I know it seems silly to be asking, but like I said, I’ve tried both dradisframework and dradisframework-ce repos on several machines, and I can’t for the life of me get it all working.

Thanks in advance for helping me get Dradis set up.

Nice that you found dradisframework-ce, it is supposed to be in stealth mode for now (it will become the main Dradis repo for v3.1 and onwards, but for now it’s only half-working), please use dradisframework for the time being.

Have you followed the Install from Git instructions? Where do you get stuck in the process?

Yes, I have tried that. I think the main issue is not having the correct dependencies, then having stuff half-install and break itself. Although, I could be wrong. Do you have a solid list of dependencies, as well as what version of Ruby, etc should be running?

I am able to get it running, however some of the import things error out, and also the HTML/PDF export errors out.

I’ll boot up a fresh VM and run through my install process to update what exactly I’ve done and where specifically I’m having trouble.


Okay, so it is on running ruby bin/setup.

Here is term output of running sudo ruby bin/setup (if I don’t use sudo, I get lots of permission denied stuff)

I’d really just like a start-to-finish guide to get it 100% working. I’ve messed with the Ruby stuff in previous machines and was able to at least get Dradis to start, however none of the import or exports worked then.

Something like this: Dradis Framework GuidesDradis Framework Guides: Installing Dradis on Ubuntu but that seems a bit out of date, and didn’t work when I tried.


You should run a ‘sudo bundle install’ and see if that succeeds. Afterwards you can do the ‘ruby bin/setup’ again, that may solve your issues.

It will depend on your system, but sudo really shouldn’t be necessary. If you run the commands with sudo (e.g. sudo bundle install you’ll be modifying the OS-level Ruby install.

That being said, yes you are right, we need a start-to-finish guide, and @rachkor is working on it. However there is a bit of house keeping we need to take care of. We’re going through a very significant effort to make Dradis CE and Dradis Pro codebases converge again (so we fix bugs in one place for both editions). There are some bits and pieces left, but the lion’s share of the work is done. Once it’s finished the first page we’re putting together is the zero-to-running step-by-step guide.

Watch this space!

As of today we have a new current install guide: