Can't enter configuration

When I try to go to :3000/configurations_path
I see an error:
No route matches [GET] “/configurations_path”

Rails.root: /home/ubuntu/dradisframework

Here’s the Framework trace:

actionpack (4.1.9) lib/action_dispatch/middleware/debug_exceptions.rb:21:in call' actionpack (4.1.9) lib/action_dispatch/middleware/show_exceptions.rb:30:in call’
railties (4.1.9) lib/rails/rack/logger.rb:38:in call_app' railties (4.1.9) lib/rails/rack/logger.rb:20:in block in call’
activesupport (4.1.9) lib/active_support/tagged_logging.rb:68:in block in tagged' activesupport (4.1.9) lib/active_support/tagged_logging.rb:26:in tagged’
activesupport (4.1.9) lib/active_support/tagged_logging.rb:68:in tagged' railties (4.1.9) lib/rails/rack/logger.rb:20:in call’
actionpack (4.1.9) lib/action_dispatch/middleware/request_id.rb:21:in call' rack (1.5.2) lib/rack/methodoverride.rb:21:in call’
rack (1.5.2) lib/rack/runtime.rb:17:in call' activesupport (4.1.9) lib/active_support/cache/strategy/local_cache_middleware.rb:26:in call’
rack (1.5.2) lib/rack/lock.rb:17:in call' actionpack (4.1.9) lib/action_dispatch/middleware/static.rb:84:in call’
rack (1.5.2) lib/rack/sendfile.rb:112:in call' railties (4.1.9) lib/rails/engine.rb:514:in call’
railties (4.1.9) lib/rails/application.rb:144:in call' rack (1.5.2) lib/rack/lock.rb:17:in call’
rack (1.5.2) lib/rack/content_length.rb:14:in call' rack (1.5.2) lib/rack/handler/webrick.rb:60:in service’
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p551/lib/ruby/1.9.1/webrick/httpserver.rb:138:in service' /home/ubuntu/.rvm/rubies/ruby-1.9.3-p551/lib/ruby/1.9.1/webrick/httpserver.rb:94:in run’
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p551/lib/ruby/1.9.1/webrick/server.rb:191:in `block in start_thread’

Why that happens?
How can I fix it?


Sorry about that, we have already fixed the problem in the release-3.0 branch (see commit history) if you:

$ git checkout release-3.0

And restart the server you should be able to access the Configurations page.


I have the same error when trying to access the configuration.

I tried the git checkout release-3.0 command but I still receive the same error.

Can you help?

Please git pull your clone of the code, these should be fixed by now:

Alternatively checkout the new “3.0.0.rc2” all-in-one packages: